ExampleRouter Config

Here is an example of a router configuration. This is a basic configuration, if you were to do this to your router the IP addresses would be different but the commands would be the same. This configuration was done without the setup, it was done manually.

Router>enable

Router#config t

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname Butte

Butte(config)#line con 0

Butte(config-line)#password cisco

Butte(config-line)#login

Butte(config-line)#lin aux 0

Butte(config-line)#password cisco

Butte(config-line)#login

Butte(config-line)#enable password cisco

Butte(config)#int e0

Butte(config-if)#ip address 150.50.2.1 255.255.254.0

Butte(config-if)#no shut

Butte(config-if)#int s0

%LINK-3-UPDOWN: Interface Ethernet0, changed state to up

Butte(config-if)#ip address 150.50.4.1 255.255.254.0

Butte(config-if)#clock rate 56000

Butte(config-if)#no shut

Butte(config-if)#

%LINK-3-UPDOWN: Interface Serial0, changed state to down

Butte(config-if)#router rip

Butte(config-router)#network 150.50.2.0

Butte(config-router)#network 150.50.4.0

Butte(config-router)#ip host Butte 150.50.1.1 150.50.4.1

Butte(config)#ip host Billings 150.50.6.1 150.50.4.2

Butte(config)#exit

Butte#

%SYS-5-CONFIG_I: Configured from console by console

Butte#